History of MembersPage/FPhil/Install
Older Newer
2018-02-09 10:16:09 . . . . i16-les01-ntr-212-194-188-15.sfr.lns.abo.bbox.fr [cleaning...]
2012-11-02 03:01:48 . . . . pes75-2-78-192-98-74.fbxo.proxad.net [photos&crank dwell concern]
2012-10-17 14:17:34 . . . . pes75-2-78-192-98-74.fbxo.proxad.net [first runs distributorless]
2011-09-13 10:34:51 . . . . 85.47.126.78.rev.sfr.net [Bad start for odd engine without DIS]
2011-09-11 11:47:05 . . . . 234.171.112.78.rev.sfr.net [Quick start impossible with DIS ?]
2011-09-02 15:59:24 . . . . 53d82fd0.adsl.enternet.hu [1-crankrot startup note]
2011-09-01 07:52:00 . . . . 198.239.9.109.rev.sfr.net [Maserati First Start]
2011-08-18 06:36:05 . . . . gwinternet.thalesgroup.com [Noisy Vems?]
See complete list (8 entries)


Changes by last author:

Deleted:
I made a cradle to install Vems under the dashboard. This is not too far from the ignition and injection ecu from where I would get the signal sensors.

This picture would only see something to someone who already knows the car ;) I set the Vems under the dashboard

install1.jpg

Noise from Vems

Next I made the harness between injection ecu Mplex and Vems following the documentation instruction concerning the "grounds";

Everything is coming from Mplex (ground, 12V etc) through and 8 poinst external connector: triggers signal is one wire shield on the Vems side

Then I bench test it.

* trigger errors at low speed

* no trigger errors when crank trigger shield is ground on the Mplex side.

* no trigger error when using flying single wires to connect Vems

* 200mv 2kHz noise on any grounds of the Vems

* no noise on the Mplex side

* Vems noise independent of rpm.

* 0 ohm between Ground 5,32,21,22

* 0.4, 0.5ohm between Ground 26 (senor groung) and the others (so GND5 and GND26 are not connected hard).

To debate ..

- I conclude that there is a noise radiated by the multiple ground wires coming out the genboard the more wires, the more noise)

- that it is better not to shield the trigger on Vems side

- besides I do not understand much the physics or the maths of the recommendation: "all 4 GND5 (power-ground) pins must be connected to GND (EC36pin26) with short wires max 40cm (1.3 feet) from EC36 connetor to avoid damage caused by GND5 voltage jumping too high above GND (when ignition transformers, injectors or other loads are driven) ..." from "GenBoard/Manual/GroundConnections .

Why not make a hard connect Ground 5,32,21,22 (good section). (This will save some pins) ??

* I got from the Vems chat some answer: the Econoseal pins have a 10A current limitation, so if one has 45A to ground this needs some pins. Indeed this can occurs at high speed if one allows 7A through each coil.

* I also was suggested to test the resistance of my ground wiring to explain the noise on the trigger

**alright, by luck I have a power supply with adjustable current so I can get the resistance from the voltage drop. I got 18.8 10^-3 Ohm The wire is 1.5mm2 about 0.6m long and there is a connector. So its ok, the connector resistance would be about 4 10^-3 Ohm.

** In any case I shield the trigger wires on the Mplex side and I added an extra 1.5mm2 ground wire (see the picture) -> no more trigger errors at 1000rpm

VemsWire2.jpg

The Mplex electronics and the MPlex case are together grounded to the battery through the car hardness and to the car body through the case.

First firing

For the first start I kept the injection ecu of the car (IAW) and I subtitute Mplex with Vems. So set the Vems ignition to drive only 2 pins, one to fire banK A the other to fire bank B from the 2 coil through the distributor.

The engine started at first try Hurrah !

There is picture wich only shows the 2 wires from Vems to the coils! Nothing spectacular !

install2.jpg

It takes more about one and half turn to start, too much for my taste

Q: Are there some settings to tune? Advance Filtering for the crank trigger

* not much. When you change to DIS ignition, it is impossible to start quicker anyway (with any ECU).

** ??? Why, the ecu does not know about the distributor, and the distributor distributes any first fire ?

** While some triggers can sync quick even with DIS, like MembersPage/YasecElise ,

** this maserati trigger can only start quick with distributor - the factory ECU can only handle this trigger and is obviously optimised for that

*** Yes I told about the switch case firmware with 12 (2x6) trigger events which decides the ignition for bank A or B

** if there are 30+ installs completed and running with distributor, we'll work on faster initial-sync firmware mod for this trigger.

*** oh, oh!! there would be probably none because I presently use the distributor only for testing. I have made a switch to toggle between MPlex ignition and Vems Ignition while driving so I still keep one foot on good earth

Bad Start for odd engine without DIS

I understand the slow start of my odd engine using DIS. See below

Start.JPG

The firing n 1 sent by Vems is good so the engine accelerate.

The firing n2 which has to occur 150 (= 127+33-10) using a 33 spark delay is off, probably because is computed from the speed before the acceleration.

I try to change the trigger filter value which was 150. 120 -> idem,, 90 no start, 0 no start

Hopefully the distributor skips this mess off

Q. What can we do ?

----

October 2012

After some 'odd' time and many improvements, fw finally reached version 1.2.6 which works successfully for the odd firing maserati engine with the very use of the original crank and cam triggers (see http://www.vems.hu/wiki/index.php?action=find&find=MembersPage%2FFPhil%2FOddFireWastedSparkEvilStartUp)

I have installed the 3 coils (2x1 bosch-mercedes coil ) as shown here (fuel injection is still done by the OEM IAW ecu.

bobine%20023.jpg

The cable are Beru copper wires, the Beru connector at the coils have a 2.2kOhm resistance.

I had to use the distributor to find out that the first cylinder to be fired (#0 for the Vems h[2] table )is cylinder #2 and I discovered afterwhile the nice VT testing mode for the ignition links (I had swapped pins by error).

I have driven the car for about 200km with this new distributorless ignition. It runs much better, I think I got more benefit than one usually gets after replacing old distributor and sparks for new. Idle is very steady and regular, more power at low speed (4th gear can be run now at a quite low RPM, no problem to reach 6000rpm or more...

Here is a log and a view of the log. Boost control with a target @1.9 bar (for speed <5900rpm, view shows 2.02bar @ 3624 rpm)) is done by Vems. Knock control is by the OEM Microplex ignition ecu.

http://www.vems.hu/files/maserati/v3.3_u003856-2012.10.15-15.53.40.zip

logview.jpg

----

November 2012

* Some photos of the coil install

coil2x1-2.jpg

coil2x1.jpg

* Dwell for cranking when cold weather

I get a long crank period when the battery is low (10V) because of cold temperature. The dwell is set at 3.5 ms when 14V.

I suspect that the crank dwell is not well compensated by the fw 'bike start'1.2.6