MembersPage/TonciLoncar/QuestionsAndAnswers

Subpage of MembersPage/TonciLoncar

Questions & answers:

I have vems v3.1 serial nr. 56...

Hardware problems

V-3.1-fets.jpg

I'd really be more willing to answer ontest pages where your subsystems are organized thematically (instead of a huge unorganized list). Eg. separate page for idle. That would converge to a nice doc of your setup.

Q: Is this setup on the pic OK?

A: Yes, the switches are mounted in right direction, electronically. However you should do something so they do not break off due to vibration. The IGBT might need some heatsinking too, depending on coil type and dwell configuration.


Q: Can HALL and TPS share +5V?

A: Yes. (MAP also)


Q: What parts do I need to get to install DD FlyBack on my V3.1?

A: 6.8V or 20V SMB footprint diode which was just added to rescue kit

Q: So I need to solder 6.8V or 20V SMB footprint diodes on places for diodes

A: NO !!!

The FlyBack SMB diodes that are on the schematic must always be there, there was never an option about that

mount 0V (=wire), 6.8V or 20V SMB zener (transient protection diode) on the places that are R2512 pads in the schematic: perfect footprint for mounting SMB diodes. Just follow GenBoard/Manual/DDFlyback


Q: how can I connect VR sensor. What goes to VR+ and what to VR- side of EDIS sensor?

A: VR- goes to GND. VR+ to trig1 (primary trigger) input. You need to short the onboard jumper (with max 10k) so the VR+ signal makes it's way to the LM1815 input. For more detailed answer ask on the relevant page. (maybe InputTrigger/AnalogSide)

A2 (same): The VR sensor should be connected with one side (vr+) to the trig1 input, the other 2 pins should be connected to GND (one is vr- signal, the other is cable shield) - DB

Thanks Dave


Q: For lm1815 circut I need to solder D14 (3.9V diode) and short SJ6 right? Anything else?

A: The components you need to mount are listed on the BuildProcedures/SectionThree page, please check schematic to be sure - DB


Q: I can't get lightbulbs connected instead of injectors to work. How can I test if hardware on v3.1 is ok? I have connected input trigger and I have rpm readout in MT but it just won't fire injectors (lightbulbs). My h[0] tables is h[0] = 01 02 04 08 00 00 00 00 and config.alternate = 03 and I am using injectors a,b,c and d so that shouldn't be the problem, and I have FETDRIVER_INVERTING in my make. I have constant 5V output on FET gates no matter how RPM or TPS change.

What can I check?

A:

-MAP signal (with MAP=0 pulsewidth can be zero or very low)

-measure the other PORTA pins as well (maybe you measure the wrong pins)

-try to map h[0] to other pins (maybe you already ruined some pins of AVR)

-check the injector pulsewidth on LCD or in MegaTune

-try mdh.. see testing on GenBoard/Manual/DigitalOut

-There is a good chance it's output is shorted. Did you check that with DVM when the chip was unsoldered? Shorted output could have been the reason for the previous smoke (it never smokes just because).

-Also check FET driver supply, just to be sure.

-This is the problem. It needs 6V minimum. Probably the diode that powers it from 14V is broken. Short the diode.)

THANKS Marcell!

Q: Can I use diode that I've got from Marcell for D14 (needed for VR) on the place D6 (FET drivers suply)or I'll just short D6?

A: D6 type is originally LL4148 (small current SOD80 footprint diode) but a short will do just fine. Really, the diode was replaced by a short on v3.2 in fact. The diode was originally intended to protect the FETdrivers from a reversely applied supply; but we found that if the big transient-eater diode fails due to such an abuse, the board dies anyway.


Q: I have measured voltage at my V3.1 input and it was arround 10V, but in MT it says that it is 14V, then I tryed to power it with 12.5V, and in MT it says that it is arround 17V. Is this OK?

Besides the reading it causes no problems (changes dwell and injpwm duty somewhat).

Fix:

You have to follow GenBoard/InitialConfig, see batt_cal. The variable name and LCD text (also in global.h) is a very good hint that this is related to VBatt:

 uint8_t batt_cal;	// VBatt calibration appr.BC=default

Decrease batt_cal.


Triger problem

Q: (12.06.2004) I have tried to start the engine yesterday and I've find a new problem. I've done some testing before with light bulbs and everithing worked OK but wbo2 sonde was disconected. I've tested wbo2 and it worked OK, but yesterday when I connected everithing together there was a problem. With engine standing still rpm was reading 800-1200 rpm and injectors were working. When I disconected wbo2 everithing was OK, then I tried again with wbo2 connected and there was the same problem but then I disconected trigger and everithing was ok again. So there is a problem when wbo2 and trigger sensors are connected, what can I do to solve it?

A:

-It is most likely caused by bad grounding. Don't reconnect WBO2 probe to a running engine. (disconnect at idle should not cause problem, but better shut off engine).

-I really don't want to guess how you did it. Check GenBoard/Manual/InitialTesting/VerThree on how it should be done. You can split GND-part to a separate page because of importance (so that part can be referred easily and more verbosity is allowed). If you're not sure of the wording (which is relatively simple: connect GND-s at the battery), make a drawing of your wiring, which shows the ground wires, I will review it.

-If the GND and GND5 are both properly connected with separate wires to the battery (-) you can cut the onboard connection between them (arch next to the FETdriver chips; this is only installed for safety: so bad install just causes noise instead of smoke). A cold WBO2 heater consumes 3..6A current and that can cause serious GND fluctuation without proper grounding.

-So you have trigger noise.

-Describe or draw trigger ground and trigger source and trigger setup in general.

-This sounds like trigger noise in any case.

-Something is very wrong here. If it is a table-setup, the IGBT cannot smoke with lightbulbs (not coils) connected. If it is an engine-setup, IGBT cannot smoke, it just blows the 5A fuse that is used in the coil power (usually +14V side, separate 5A fuse for each coil). But if it's engine setup, you connected a test-trigger-wheel? (that alone should not hurt by itself, if the engine is otherwise stopped)

-No.

Q: Here is the problem: my vems V3.1 when it has connected trigger, wbo2 sonde and light bulbs instead of injectors and coils is geting false rpm info as soon as I turn ON the power. Bulbs are turning on and off and rpm readout is around 800-1200rpm. Then I turn trigger wheel to arround 300rpm and when wheel stops then everithing is ok: bulbs are off and rpm is 0. False rpm readout does not appear if trigger or WBO2 sonde is disconected.

-This is a very strange problem indeed, SJ6 and SJ1 is correctly jumpered. By jumpering SJ3 to VCC you can increase the threshold value. But I feel that that would be a band aid in this situation, you must have a more serious problem with the trigger system. I suggest that you check that pin7 of U11 isn't shortcircuited to GND through C38 or R87. (Should be high ohm)

-I haven't actually measured on an actual board, but the 1.6Mohm resistor makes me belive that anything below 1Mohm is wrong and 1.1k _will_ cause false triggs! I think that you found what's wrong with your board. Unsolder C38 and R87 and R87. Measure resistance after unsoldering each component. If resistance is high ohm (probably open circuit) with them unsoldered fit a new capacitor and unless you can easily source a 1-1.6Mohm resistor locally (not likey to be in rescue kit) measure that the R87 is ok (1.6Mohm) when unsoldered from the board. Then fit it again and check resistanse from pin 7 to gnd again. If it's still 1.1k with them unsoldered you should remove the chip and fit a new one.

Because connecting pin5 of LM1815 to VCC disables the adaptive hysteresis. It might work, but adaptive hysteresis is good for suppressing noise.

I also suggest that you measure the AC voltage at pin 3 of U11,(measure between GND very close to the chip and pin 3). If you have more then a few mV at this pin you have a problem. Please write what you see here when there is oscillation and when there is no oscillation.

That is why you don't want to connect a VR sensor- to the GND5, but to GND. Also, GND5 and GND should only be connected at the battery for the very same reason.

Measure the above ground-noise relative to VR- (or VR- relative to LM1815 GND)

I'm almost certain that your VR- is not connected properly to GND. (maybe to GND5? or VR- and GND meet near battery (bad) instead of near EC36 connector (good).

-But back to your problem there could be some small peaks that don't show up in the AC reading, it would help a lot if you could check the wave form with a scope. if there is noise C30 (which helps shape the input signal) may be broken, try replacing it if you don't have a scope 1nF is will give you a 16kHz filter frequency, you could easily have a bit more here for most applications. As an example my engine would run with a 33n capacitor, but with multitooth you are probably limited to 2.2n. Also check that R55 is around 10k, if it is shorted the filter isn't working. Fitting a 100n for C30 would be good for testing if you don't have scope, if it false triggs with that we can start looking elswhere (to low rpm limit to allow the engine to run with multitooth, but good for bench testing).

-If possible replace C39, it's the chip's supply cap. If that is broken there will be strange results. Also fit C79, it's one of the panic noise suppressor capacitors, it will improve the supply. BTW, only change one thing at a time! You will not know what fixed (or hid) the problem othewise.

-If we go back to the SJ3 jumper again, in the open setting the threshold voltage will be selfadjusting. When jumpered to VCC the treshold voltage will be 220mV, unless the voltage swing to 220mV the chip will ignore the next 0v crossing. If it is jumpered to gnd the threshold value will be 0v (+-25mV) and pretty much everything will trigg the chip. In the Open setting the threshold voltage will be around 80% of the peak value on Vin.

This may seem strange but is power connected to pin25 on EC36-Yes

And if all coils injectors and WBO² are un-pluged will it still power up-Yes it will

Also check if the VR pickup has a short to ground. I see that you tested more then one so I guess not.-No it has 772 ohm resistance from VR+ to VR-

If you just jump jp12 to TRIGG2_CONN will it still see RPM at powerup? - I've connected jp12 and jp13 (is that right?) and it didn't help. was this with or without the VR connected to jp12,jp13 too? -It was without VR connected to jp12 and jp13, I only have one VR connected to tigg1 conection (EC36-27) and gnd.

also is this powered by a car battery or a powersupply? -it is powered by a car battery


I've soldered a bridge on SJ3 (to +5V field closer to pin1) and now everithig works PERFECTLY. I would just like to ask what is the downside of this kind of setup? Why did you call it a band aid?

Because connecting pin5 of LM1815 to VCC disables the adaptive hysteresis. It might work, but adaptive hysteresis is good for suppressing noise.

This is getting to the point that should not be started without scope.-sorry I dont have a scope

lm1815.jpg


Idle config issue

Now the engine is running very good at idle, but I couldn't get it to idle lower than 1200-1300rpm. Highest possible rpm at idle was arround 1500rpm. Then I've find adjusting screw on idle valve (BOSCH 0 280 140 516) and adjust it. Now it runs fine at 900 rpm, but now the highest rpm that I can get at idle is 1100rpm. So acording to that idle range is arround 200-300rpm.

Here is my [config] file.

This is almost certainly an iac reference positions and PID configuration problem: integral value is too low so the valve cannot open sufficiently

Using mdi.. forced iac positions and is needed anyway to tune reference positions (in function of coolant temp).

After good reference positions are tuned check the LCD page that shows you iac position (mlp03 ?). If you see that iac.position reaches iac_max_steps=BF (unlikely) increase iac_max_steps too - up to FF


Tuning problem

I have tuning problem...at idle engine runs nice, but when i pres the throtle and hold it at 5% engine is changing rpms from 1400 to 3500 rpm, it is not steady. I have VE and spark tables that dave brul tuned for almost the same engine so I don't think they are the problem (I tried to change them and it didn't help). Here are the pics from log file:

graph.jpg

graph2.jpg

note the ve value on this pic (that is causing engine rews to go up and down)

and here is hole log file: [datalog] (right click - save target as)

The problem is that VE value is changing too fast and it goes from 10 to 80 to 20 to 120...even tough lowest value in ve table is 45, and this is hapening when I press throttle 5%-10% and tray to keep rews at 1500rpm. Could this be some sort of config problem? Can you check my map sensor config values? I use std. 1.5 bar motorola sensor. Here you can see my MembersPage/TonciLoncar/OpelKadettTurbo/Config and I am using 2004-11-24 firmware.

Problem solved!

The problem was faulty firmware (2004-11-24 version). I've been trying to upgrade to latest firmware couple of times but the car woudn't start with it. Then I realised that old and new firmware had switched ignition outputs (I am using wasted spark setup). Afther fixing this, engine started with new firmware and all problems were gone :-) ...


Tachometer connection

The tacho on a vems 3.1 is same as on any v3.x. A recent firmware is needed, and a free output.

In general, an IGBT output is used with a 220uH [inductor and 22 Ohm resistor]

A standard tacho that was connected to coil (4 cylinder car with distributor) would show 1/2 RPM with wasted spark setup you have now.


2006.11.15

Eratic idle problem

I have been driving with vems v3.1 for more than 6 months and 5000km now and it works very nice. I have been on 6 drag race events with best time of 13.8 sec with fwd car with normal road tires, so it realy works very nice. I have one problem thou...sometimes it starts to idle eraticly for no obvies reason, and sometimes it works just fine (with same config and table setup) . I have been trying to find mechanial reson like fpr, air leaks or something like that but everithing seems to be ok. It is not dependant on temperature eather. I was thinking could there be a problem with primary triger hardware?