History of MembersPage/RijaRobinson
Older Newer
2018-02-06 05:58:09 . . . . catv-86-101-250-44.catv.broadband.hu [mixed projects page: splitting subpages S50B32]
2014-09-22 06:38:03 . . . . catv-80-98-222-153.catv.broadband.hu [camshaft angle control hints]
2014-09-21 00:11:58 . . . . sto95-5-78-237-254-60.fbx.proxad.net [trigger log]
2014-09-12 14:55:56 . . . . sto95-5-78-237-254-60.fbx.proxad.net [M5 V8 PROJECT]
2012-12-22 07:05:02 . . . . TrifanCatalin? [Wrong pin usage]
2012-09-19 08:58:47 . . . . adsl6-223.pool.businesstel.hu [lower measure tooth so measured position gets lower]
2012-09-19 05:24:15 . . . . adsl6-223.pool.businesstel.hu [lower measure tooth by at least 4]
2012-09-16 10:22:46 . . . . alf94-10-82-243-46-114.fbx.proxad.net [Outputs test]
See complete list (21 entries)


Changes by last author:

Deleted:
After using piggyback ECU's such as Morristech TSI and AEM Fic 6/8 and not satisfied, I decided to go standalone ECU.

Engine code: S50B32

Specs:

6 cylinder in line

Infinite variable camshaft angle on both intake and exhaust(VANOS)

displacement (cm3): 3201

JE pistons 8.5:1 compression ratio

Forged ARROW connecting Rods

Coil on plugs and full sequential

Stock cams

GT37/40 hybrid turbo

3 vr sensors

Crank 60-2

Exhaust 6+1

Intake 6

Engine management:

VEMS V3.6 Firmware 1.1.96

Dual Vanos Enabled

VEMSTUNE 1.2.4

----

Vanos preamble

* Forget cam-adjustments until the engine drives like a charm

The car already drives like charm

** so well you would take the family on a holiday: it wouldn't stall, or be nervous or misfire.

** Maybe connect light-bulb only (between PFET outputs and GND, so you can see in operation: which operates when, while you watch "sectrig position" and play with target table).

* in BMW, dual outputs actuated for sectrig (and dual for third trig). Basic operation is simple, in short:

** If measured "sectrig position" is lower than adjusted target (in the "sectrig position" table, historically called "intake" but actually sectrig is exhaust for BMW) then Output-A is activated to advance cam (remember it by: A="advance")

** if measured "sectrig position" is higher than adjusted target, then Output-B is activated to retard cam.

** third trigger is similar, but with own "Output-A" and "Output-B" outputs for the other cam (the exact econoseal pin must be configured according the setup).

** after reading the above 3 times (and understanding it), see http://vems.hu/vt/help/v3/v3_camshaft_angle_control.html for more details.

Added:
See

* MembersPage/RijaRobinson/SFiftyBthirtyTwo S50B32

** MembersPage/RijaRobinson/SFiftyBthirtyTwoVanos (Vanos subpage)

Changed:
Vanos outputs - 4 PFET outputs requested

Output tests - with solenoid disconnected and lightbulb connected

* At 0 RPM both are Inactive

** in VT / Outputs / Assign Output channels / INVERT inverts BOTH

** However that will still pass if the 2 channels are accidentally shorted.

* The "output test" checkbox (and ON/OFF button) only changes the lower channel, eg. p259/4 (or p259/6, assuming the standard channels 4,5 + 6,7 )

** so this will reveal if the 2 outputs happen to be shorted.

The diodes inside the connectors (from GND to signal) are VERY important, they are "flyback" diodes to prevent kickback from the inductive solenoids.

* The only reason to remove them is if one makes a mistake during ordering so he orders controller without P-FETS (with only N-FETS, like injector outouts), but than adding flyback diodes (eg. BY399, from signal to +12V) is necessary.

* since PFET's switch to +12V (not to GND as NFETs !!!) test all 4 PFET outputs with lightbulb connected between output and power-GND (you have all 5 grounds connected, right ???)

** eg. breaklight max 25W, 2A, min 6 Ohm or perhaps somewhat lower when cold

* first disable the camshaft-angle-control outputs, and use misc1 (or misc2) function to test the outputs (eg. with TPS).

* if all 4 PFET outputs work with misc function-test

** disable the misc output and configure the camshaft-angle-control outputs

** if you have problem with Vanos, add 2 or 4 LEDs (series resistor and series 1n4007 diode or almost any type of diode) so you can see which ones are active (2 DVM is also OK, just connect them so you don't have to hold !).

** if the trigger position shows the hydraulic does not actuate even though the ECU applies voltage, maybe the 2 solenoids are reversed (or go to the intake instead of exhaust) !

* capture vemslog and take note of your comments

Document your wiring of the 4 PFET outputs here:

* EXHAUST cam (sectrig) solenoid A (advance: DME pin 22 to EC36 pin 3 =p259/4).

** tested with solenoid disconnected and breaklight connected ? (or solenoid + resistor-diode-protected-LED ) ?

Yes: in inverted mode both bulbs are on

* EXHAUST (sectrig) Solenoid B (retard: DME pin 21 to EC36 pin 15 =p259/5)

** tested with solenoid disconnected and breaklight connected ? (or solenoid + resistor-diode-protected-LED ) ? Yes

* INTAKE (third trigger) Solenoid A (advance: DME pin 67 to EC36 pin 31 = p259/6)

** tested with solenoid disconnected and breaklight connected ? (or solenoid + resistor-diode-protected-LED ) ? Yes

* INTAKE (third trigger) solenoid B (retard: DME pin 72 to EC36 pin 30 = p259/7)

** tested with solenoid disconnected and breaklight connected ? (or solenoid + resistor-diode-protected-LED ) ? Yes

In output test mode only one bulb lights on. No short.

With the whole cam table angle target values set to max advance position the trigger position is stable until car goes into max boost. Then it falls down to max retard until throttle is released.

With the exhaust cam control disabled, the trigger position do not move and keeps its position even at boost.

Conclusion: there is no hardware failure. The only possible reason to unwanted cam retard is that the retard solenoid is fed.

See [retest-repair] or if your measurements show that 1 out of the 4 P-FET outputs (hardware) misbehaves,

* than order [v3 with 4 PFETs and reference and same notes as original]

** you'll get it without payment so you can send back the old later (within a month after receiving the new)

** or optionally pay the new with discount if it turns out the old was also good, just measurements/connections were wrong (the typical case: we told a guy from Africa about 4 times to check his WBO2 wiring because his measurements differed from the manufacturing logs of his unit, he insisted it was good, we sent him a new controller and it turned out he had pump+ connected to GND: just an example, of course not always like that )

Link the vemslog or vemscfg here !

http://vems.hu/vemstune/sharingcenter/reports.php?cmd=view&key=GRn2Fp

* at 0:19 sec the sectrig position is not following the target.

** nice info, fill in the "tested with solenoid disconnected and breaklight connected" parts above to make sure the outputs act properly independent of Vanos actuation.

** unfortunately we don't have info about vanos oil pressure, right ?

There could be 3 scenerios, your sentences will be phrased sg like:

* see ... vemslog, at sec 17.3 I apply 12V maually to hydraulic actuator ... (ECU outputs DISCONNECTED) but neither sectrig position nor third trig position moves according to vemslog (=> triggerlog will be needed for sure, and perhaps sg wrong with the hydraulic actuator HW?)

* I disabled camshaft angle outputs (both third trig and sectrig) and tested PFETs with the miscX function, but ... does not work (the other 3 works as expected).

* see ... vemslog, at sec 17.5 I measure ... on EC36/.... and ...on EC36/.... although the third trig target is configured .... higher/lower than the third trig position

Your Vanos wiring is needed (on your page) in any case, and most likely .vemslog (and .triggerlog also).

----

I kept the OEM harness and sensors to have the installation clean and OEM like.

----

Ignition coils wiring: done

Important note: traversed according the arrows (that point up) in VemsTune

----

TODO: testing the Vanos and camshaft movement.

Camshaft target table is directly related to the "sectrig position" and "third trig position" gauges:

* higher values advance,

** lower values retard

Sectrig position is normally (without cam-advance) 5-35 degrees, not 70 degrees or so. We suspect something.

* Decrease "measure tooth", say by 4.

** in other words, good window for the measured position is 10-45 or 30-70 degree, but not 70-110 deg ( so measure tooth=14 is definitely too high for your teeth, adjust max 10)

* Measured sectrig position will be 24 degrees lower,

** adjust (lower) the target position table accordingly.

* Let us know if that makes it all good

Measured = 0 ... target - 2 deg - PWM-ing range : OutputA? active and OutputB? inactive , Cam pulse too late

Measured = (target - 2 deg - PWM-ing range) ... (target - 2 deg) : OutputA? active and OutputB? PWM-ing ( closer to target = PWM duty higher )

Measured = (target - 2 deg) .... (target + 2 deg): OutputA? and OutputB? active

Measured = (target + 2 deg) .... (target + 2 deg + PWM-ing range): OutputA? inactive and OutputB? active

Measured = (target + 2 deg + PWM-ing range) ... 360 deg: OutputA? PWM-ing ( closer to target = PWM duty higher ) and OutputB? active , Cam pulse too early

Just document your wiring and measurements, and given the captured vemslog (preferrably with some comment, like "I disconnected ECU output and at 17 sec applied 12V manually to exhaust cam/... solenoid") we can inspect and review !

------------------------------------------------------------

----------------- S62B50 M5V8 ---------------------

S62B50 M5V8 '
Changed:
VEMS V3.6 VR Hall Hall
VEMS V3.6 VR Hall Hall
Added:
* there are enough digital outputs internally, so if ordering VEMS ECU with comment "+4 NFETs"

** (or even +6 or more is possible), the drivers are added inside (extrafets, s259 and p259 channels, 2nd wbo2 heater, ... max 2+8+8+1=19 strong outputs at extreme, beyond the 8 injectors and 8 ignition outputs, not counting some external v3 => AIM => round PWM outputs).